package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(?:\[[^\\\]]*(?:\\.[^\\\]]*)*\]|\([^\\)]*(?:\\.[^\\)]*)*\))\s*`)
var str = `WALL COLOR (IS \(escaped\) HERE) [SHERWIN-\[WILL\]IAMS]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}