use strict;
my $str = 'WALL COLOR (IS \\(escaped\\) HERE) [SHERWIN-\\[WILL\\]IAMS]';
my $regex = qr/\s*(?:\[[^\\\]]*(?:\\.[^\\\]]*)*\]|\([^\\)]*(?:\\.[^\\)]*)*\))\s*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";