import re
regex = re.compile(r"\s*(?:\[[^\\\]]*(?:\\.[^\\\]]*)*\]|\([^\\)]*(?:\\.[^\\)]*)*\))\s*", flags=re.MULTILINE)
test_str = "WALL COLOR (IS \\(escaped\\) HERE) [SHERWIN-\\[WILL\\]IAMS]"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)