re = /\s*(?:\[[^\\\]]*(?:\\.[^\\\]]*)*\]|\([^\\)]*(?:\\.[^\\)]*)*\))\s*/m
str = 'WALL COLOR (IS \\(escaped\\) HERE) [SHERWIN-\\[WILL\\]IAMS]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result