$re = '/\s*(?:\[[^\\\\\]]*(?:\\\\.[^\\\\\]]*)*\]|\([^\\\\)]*(?:\\\\.[^\\\\)]*)*\))\s*/m';
$str = 'WALL COLOR (IS \\(escaped\\) HERE) [SHERWIN-\\[WILL\\]IAMS]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;