#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)$"
Local $sString = "// Accept ✅" & @CRLF & _
"127.0.0.1" & @CRLF & _
"192.168.1.1" & @CRLF & _
"192.168.1.255" & @CRLF & _
"255.255.255.255" & @CRLF & _
"0.0.0.0" & @CRLF & _
"" & @CRLF & _
"// Reject ❌" & @CRLF & _
"033.33.33.33" & @CRLF & _
"127.1" & @CRLF & _
"192.168.1.256" & @CRLF & _
"-1.2.3.4" & @CRLF & _
"1.1.1.1."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")