package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)$`)
var str = `// Accept ✅
127.0.0.1
192.168.1.1
192.168.1.255
255.255.255.255
0.0.0.0
// Reject ❌
033.33.33.33
127.1
192.168.1.256
-1.2.3.4
1.1.1.1.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}