import re
regex = re.compile(r"^(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)$", flags=re.MULTILINE)
test_str = ("// Accept ✅\n"
"127.0.0.1\n"
"192.168.1.1\n"
"192.168.1.255\n"
"255.255.255.255\n"
"0.0.0.0\n\n"
"// Reject ❌\n"
"033.33.33.33\n"
"127.1\n"
"192.168.1.256\n"
"-1.2.3.4\n"
"1.1.1.1.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")