// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)$").unwrap();
let string = "// Accept ✅
127.0.0.1
192.168.1.1
192.168.1.255
255.255.255.255
0.0.0.0
// Reject ❌
033.33.33.33
127.1
192.168.1.256
-1.2.3.4
1.1.1.1.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}