$re = '/(?<!^..).(?=.{3})/m';
$str = '7108898787654351
7108-8987-8765-4351';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;