#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?!(?:\D*\d){14}$|(?:\D*\d){1,3}$)\d"
Local $sString = "71088-987876-54-351" & @CRLF & _
"7108898787654351" & @CRLF & _
"7108-8987-8765-4351"
Local $sSubst = "*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)