using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!(?:\D*\d){14}$|(?:\D*\d){1,3}$)\d";
string substitution = @"*";
string input = @"71088-987876-54-351
7108898787654351
7108-8987-8765-4351";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}