const regex = /(?!(?:\D*\d){14}$|(?:\D*\d){1,3}$)\d/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!(?:\\D*\\d){14}$|(?:\\D*\\d){1,3}$)\\d', 'gm')
const str = `71088-987876-54-351
7108898787654351
7108-8987-8765-4351`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);