import re
regex = re.compile(r"(?!(?:\D*\d){14}$|(?:\D*\d){1,3}$)\d", flags=re.MULTILINE)
test_str = ("71088-987876-54-351\n"
"7108898787654351\n"
"7108-8987-8765-4351")
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)