$re = '/(?!(?:\D*\d){14}$|(?:\D*\d){1,3}$)\d/m';
$str = '71088-987876-54-351
7108898787654351
7108-8987-8765-4351';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;