#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(env\.[a-z]+\((('[a-zA-Z_]+')|("[a-zA-Z_]+")))([, default=.*]{0})(\))"
Local $sString = "env.str('POSTGRES_DB', default=None)," & @CRLF & _
"env.str("POSTGRES_USER", default='ajdf')" & @CRLF & _
"env.str('POSTGRES_PASSWORD')" & @CRLF & _
"env.str("SECRET_KEY")" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")