import re
regex = re.compile(r"(env\.[a-z]+\((('[a-zA-Z_]+')|(\"[a-zA-Z_]+\")))([, default=.*]{0})(\))", flags=re.MULTILINE)
test_str = ("env.str('POSTGRES_DB', default=None),\n"
"env.str(\"POSTGRES_USER\", default='ajdf')\n"
"env.str('POSTGRES_PASSWORD')\n"
"env.str(\"SECRET_KEY\")\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")