$re = '/(env\.[a-z]+\(((\'[a-zA-Z_]+\')|("[a-zA-Z_]+")))([, default=.*]{0})(\))/m';
$str = 'env.str(\'POSTGRES_DB\', default=None),
env.str("POSTGRES_USER", default=\'ajdf\')
env.str(\'POSTGRES_PASSWORD\')
env.str("SECRET_KEY")
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);