package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(env\.[a-z]+\((('[a-zA-Z_]+')|("[a-zA-Z_]+")))([, default=.*]{0})(\))`)
var str = `env.str('POSTGRES_DB', default=None),
env.str("POSTGRES_USER", default='ajdf')
env.str('POSTGRES_PASSWORD')
env.str("SECRET_KEY")
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}