use strict;
my $str = 'env.str(\'POSTGRES_DB\', default=None),
env.str("POSTGRES_USER", default=\'ajdf\')
env.str(\'POSTGRES_PASSWORD\')
env.str("SECRET_KEY")
';
my $regex = qr/(env\.[a-z]+\((('[a-zA-Z_]+')|("[a-zA-Z_]+")))([, default=.*]{0})(\))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}