import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-(?:\\d*[-.]){2}";
final String string = "Ice Cold Murders- Rocco Schiavone-1-5.ts\n"
+ "Lost Girl---Where There's a Will, There's a Fae_Pick_2019_04_09_20_00.ts\n"
+ "Lost Girl-1-4-Food For Thought_Pick_2019_04_15_20_00.ts";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}