import re
regex = re.compile(r"-(?:\d*[-.]){2}", flags=re.MULTILINE)
test_str = ("Ice Cold Murders- Rocco Schiavone-1-5.ts\n"
"Lost Girl---Where There's a Will, There's a Fae_Pick_2019_04_09_20_00.ts\n"
"Lost Girl-1-4-Food For Thought_Pick_2019_04_15_20_00.ts")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")