using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bId :\s*(\d+)\b";
string input = @"1)Name : Alibaba
Id : 1341343144
Nationality : ALIEN CITIZEN
Address :
Address Source : Address Change Date :
Position SECRETARY
1)Name : TAN GENGQI
Id : 14019849314
Category : Individual
Nationality : SFAEFFE CITIZEN
Address :";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}