import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bId :\\s*(\\d+)\\b";
final String string = "1)Name : Alibaba \n"
+ "Id : 1341343144 \n"
+ "Nationality : ALIEN CITIZEN \n"
+ "Address : \n\n"
+ "Address Source : Address Change Date :\n\n"
+ "Position SECRETARY\n\n"
+ "1)Name : TAN GENGQI \n"
+ "Id : 14019849314 \n"
+ "Category : Individual \n"
+ "Nationality : SFAEFFE CITIZEN\n"
+ "Address :";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}