import re
regex = re.compile(r"\bId :\s*(\d+)\b", flags=re.MULTILINE)
test_str = ("1)Name : Alibaba \n"
"Id : 1341343144 \n"
"Nationality : ALIEN CITIZEN \n"
"Address : \n\n"
"Address Source : Address Change Date :\n\n"
"Position SECRETARY\n\n"
"1)Name : TAN GENGQI \n"
"Id : 14019849314 \n"
"Category : Individual \n"
"Nationality : SFAEFFE CITIZEN\n"
"Address :")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")