// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bId :\s*(\d+)\b").unwrap();
let string = "1)Name : Alibaba
Id : 1341343144
Nationality : ALIEN CITIZEN
Address :
Address Source : Address Change Date :
Position SECRETARY
1)Name : TAN GENGQI
Id : 14019849314
Category : Individual
Nationality : SFAEFFE CITIZEN
Address :";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}