$re = '/\bId :\s*(\d+)\b/m';
$str = '1)Name : Alibaba
Id : 1341343144
Nationality : ALIEN CITIZEN
Address :
Address Source : Address Change Date :
Position SECRETARY
1)Name : TAN GENGQI
Id : 14019849314
Category : Individual
Nationality : SFAEFFE CITIZEN
Address :';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);