# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*[()](?=(?:[^@]*@[^@]*@)*[^@]*$)\s*//gm;t' <<< "( [15] == @value 1@ || [15] == @value 2@ ) && ( [5] == @value 3 (ignore these)@ || [5] == @value 4@ ) || ( [2] == @value 5@ )"