use strict;
my $str = '( [15] == @value 1@ || [15] == @value 2@ ) && ( [5] == @value 3 (ignore these)@ || [5] == @value 4@ ) || ( [2] == @value 5@ )';
my $regex = qr/\s*[()](?=(?:[^@]*@[^@]*@)*[^@]*$)\s*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";