const regex = /\s*[()](?=(?:[^@]*@[^@]*@)*[^@]*$)\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*[()](?=(?:[^@]*@[^@]*@)*[^@]*$)\\s*', 'gm')
const str = `( [15] == @value 1@ || [15] == @value 2@ ) && ( [5] == @value 3 (ignore these)@ || [5] == @value 4@ ) || ( [2] == @value 5@ )`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);