re = /\s*[()](?=(?:[^@]*@[^@]*@)*[^@]*$)\s*/m
str = '( [15] == @value 1@ || [15] == @value 2@ ) && ( [5] == @value 3 (ignore these)@ || [5] == @value 4@ ) || ( [2] == @value 5@ )'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result