$re = '/\s*[()](?=(?:[^@]*@[^@]*@)*[^@]*$)\s*/m';
$str = '( [15] == @value 1@ || [15] == @value 2@ ) && ( [5] == @value 3 (ignore these)@ || [5] == @value 4@ ) || ( [2] == @value 5@ )';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;