#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-zA-Z]{3}\d{3})\s([a-zA-Z]{9}\s+\((\d{4})\)\s+\*[a-zA-Z]{3})\s+([a-zA-Z]+\d\w)\s+\.([a-zA-Z]+)\s(\d+)\s+"
Local $sString = " LMZ333 ALLOTMENT (0000) *TSC " & @CRLF & _
"HDQRM5I " & @CRLF & _
".MADRIIB 160846 " & @CRLF & _
"MADIB N4MPK/HELIB0150/1949417/HEL/IB/A/FI//RC//" & @CRLF & _
"HDQ5I N4MPK" & @CRLF & _
"1CUVILEON/CARLOS EDUARDO" & @CRLF & _
"1CONTRERASARNAEZ/MARIA BEGONA 1ROBLEDOCONTRERAS/PATRICIA " & @CRLF & _
"5I8397J/IB2198J25JUN RZGMAD CS1/0850 1220" & @CRLF & _
"5I8327J/IB2194J06JUL MADRZG CS1/1745 2115" & @CRLF & _
"OSI 5I CTCP 34606686051-M" & @CRLF & _
"OSI 5I POSI-DSAC//MADIB08AB/I/1" & @CRLF & _
"OSI 5I CARLOSCUVILIN//GMAIL.COM" & @CRLF & _
"= "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")