package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z]{3}\d{3})\s([a-zA-Z]{9}\s+\((\d{4})\)\s+\*[a-zA-Z]{3})\s+([a-zA-Z]+\d\w)\s+\.([a-zA-Z]+)\s(\d+)\s+`)
var str = ` LMZ333 ALLOTMENT (0000) *TSC
HDQRM5I
.MADRIIB 160846
MADIB N4MPK/HELIB0150/1949417/HEL/IB/A/FI//RC//
HDQ5I N4MPK
1CUVILEON/CARLOS EDUARDO
1CONTRERASARNAEZ/MARIA BEGONA 1ROBLEDOCONTRERAS/PATRICIA
5I8397J/IB2198J25JUN RZGMAD CS1/0850 1220
5I8327J/IB2194J06JUL MADRZG CS1/1745 2115
OSI 5I CTCP 34606686051-M
OSI 5I POSI-DSAC//MADIB08AB/I/1
OSI 5I CARLOSCUVILIN//GMAIL.COM
= `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}