import re
regex = re.compile(r"([a-zA-Z]{3}\d{3})\s([a-zA-Z]{9}\s+\((\d{4})\)\s+\*[a-zA-Z]{3})\s+([a-zA-Z]+\d\w)\s+\.([a-zA-Z]+)\s(\d+)\s+", flags=re.MULTILINE)
test_str = (" LMZ333 ALLOTMENT (0000) *TSC \n"
"HDQRM5I \n"
".MADRIIB 160846 \n"
"MADIB N4MPK/HELIB0150/1949417/HEL/IB/A/FI//RC//\n"
"HDQ5I N4MPK\n"
"1CUVILEON/CARLOS EDUARDO\n"
"1CONTRERASARNAEZ/MARIA BEGONA 1ROBLEDOCONTRERAS/PATRICIA \n"
"5I8397J/IB2198J25JUN RZGMAD CS1/0850 1220\n"
"5I8327J/IB2194J06JUL MADRZG CS1/1745 2115\n"
"OSI 5I CTCP 34606686051-M\n"
"OSI 5I POSI-DSAC//MADIB08AB/I/1\n"
"OSI 5I CARLOSCUVILIN//GMAIL.COM\n"
"= ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")