#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "Results = (\d+)"
Local $sString = "Results = 999"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)