use strict;
my $str = 'Results = 999';
my $regex = qr/Results = (\d+)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";