import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<name>.+?)[\\r\\n](?<datetime>.+?)[\\r\\n](Region: +(?<region>.*)[\\r\\n]Generated By: +(?<generatedBy>.*)[\\r\\n]((?<xommands>.+?)[\\r\\n])*?(?=.+?[\\r\\n].+?[\\r\\n]Region))*";
final String string = "The Insurance Place Agency, LLC\n"
+ "2018/12/26 22:26:07\n"
+ "Region: null\n"
+ "Generated By: jmainer\n"
+ "New-HSAgency -AgencyName ''00018097''\n"
+ "New-HSAgencyGPO -AgencyName ''00018097''\n"
+ "New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''\n"
+ "The Insurance Place Agency, LLC\n"
+ "2018/12/26 22:26:07\n"
+ "Region: null\n"
+ "Generated By: jmain222er\n"
+ "New-HSAgency -AgencyName ''00018097''\n"
+ "New-HSAgencyGPO -AgencyName ''00018097''\n"
+ "New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''\n"
+ "The Insurance Place Agency, LLC\n"
+ "2018/12/26 22:26:07\n"
+ "Region: null\n"
+ "Generated By: jmainer\n"
+ "New-HSAgency -AgencyName ''00018097''\n"
+ "New-HSAgencyGPO -AgencyName ''00018097''\n"
+ "New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}