const regex = /(?<name>.+?)[\r\n](?<datetime>.+?)[\r\n](Region: +(?<region>.*)[\r\n]Generated By: +(?<generatedBy>.*)[\r\n]((?<xommands>.+?)[\r\n])*?(?=.+?[\r\n].+?[\r\n]Region))*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<name>.+?)[\\r\\n](?<datetime>.+?)[\\r\\n](Region: +(?<region>.*)[\\r\\n]Generated By: +(?<generatedBy>.*)[\\r\\n]((?<xommands>.+?)[\\r\\n])*?(?=.+?[\\r\\n].+?[\\r\\n]Region))*', 'gm')
const str = `The Insurance Place Agency, LLC
2018/12/26 22:26:07
Region: null
Generated By: jmainer
New-HSAgency -AgencyName ''00018097''
New-HSAgencyGPO -AgencyName ''00018097''
New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''
The Insurance Place Agency, LLC
2018/12/26 22:26:07
Region: null
Generated By: jmain222er
New-HSAgency -AgencyName ''00018097''
New-HSAgencyGPO -AgencyName ''00018097''
New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''
The Insurance Place Agency, LLC
2018/12/26 22:26:07
Region: null
Generated By: jmainer
New-HSAgency -AgencyName ''00018097''
New-HSAgencyGPO -AgencyName ''00018097''
New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}