# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<name>.+?)[\r\n](?<datetime>.+?)[\r\n](Region: +(?<region>.*)[\r\n]Generated By: +(?<generatedBy>.*)[\r\n]((?<xommands>.+?)[\r\n])*?(?=.+?[\r\n].+?[\r\n]Region))*"
test_str = ("The Insurance Place Agency, LLC\n"
"2018/12/26 22:26:07\n"
"Region: null\n"
"Generated By: jmainer\n"
"New-HSAgency -AgencyName ''00018097''\n"
"New-HSAgencyGPO -AgencyName ''00018097''\n"
"New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''\n"
"The Insurance Place Agency, LLC\n"
"2018/12/26 22:26:07\n"
"Region: null\n"
"Generated By: jmain222er\n"
"New-HSAgency -AgencyName ''00018097''\n"
"New-HSAgencyGPO -AgencyName ''00018097''\n"
"New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''\n"
"The Insurance Place Agency, LLC\n"
"2018/12/26 22:26:07\n"
"Region: null\n"
"Generated By: jmainer\n"
"New-HSAgency -AgencyName ''00018097''\n"
"New-HSAgencyGPO -AgencyName ''00018097''\n"
"New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.