use strict;
my $str = 'The Insurance Place Agency, LLC
2018/12/26 22:26:07
Region: null
Generated By: jmainer
New-HSAgency -AgencyName \'\'00018097\'\'
New-HSAgencyGPO -AgencyName \'\'00018097\'\'
New-HSUser -UserName \'\'18097_username\'\' -FirstName \'\'User\'\' -LastName \'\'Name\'\' -AgencyName \'\'00018097\'\' -Password \'\'LHdfzJYJOwH5\'\'
The Insurance Place Agency, LLC
2018/12/26 22:26:07
Region: null
Generated By: jmain222er
New-HSAgency -AgencyName \'\'00018097\'\'
New-HSAgencyGPO -AgencyName \'\'00018097\'\'
New-HSUser -UserName \'\'18097_username\'\' -FirstName \'\'User\'\' -LastName \'\'Name\'\' -AgencyName \'\'00018097\'\' -Password \'\'LHdfzJYJOwH5\'\'
The Insurance Place Agency, LLC
2018/12/26 22:26:07
Region: null
Generated By: jmainer
New-HSAgency -AgencyName \'\'00018097\'\'
New-HSAgencyGPO -AgencyName \'\'00018097\'\'
New-HSUser -UserName \'\'18097_username\'\' -FirstName \'\'User\'\' -LastName \'\'Name\'\' -AgencyName \'\'00018097\'\' -Password \'\'LHdfzJYJOwH5\'\'';
my $regex = qr/(?<name>.+?)[\r\n](?<datetime>.+?)[\r\n](Region: +(?<region>.*)[\r\n]Generated By: +(?<generatedBy>.*)[\r\n]((?<xommands>.+?)[\r\n])*?(?=.+?[\r\n].+?[\r\n]Region))*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}