using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(ATK 30)\s*";
string substitution = @" \1 ";
string input = @"Product desingATK 30Trace back. TheATK 30 is a nice device. ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}