import Foundation
let pattern = #"\s*(ATK 30)\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Product desingATK 30Trace back. TheATK 30 is a nice device. "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" \1 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)