re = /\s*(ATK 30)\s*/m
str = 'Product desingATK 30Trace back. TheATK 30 is a nice device. '
subst = ' \\1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result