use strict;
my $str = 'Product desingATK 30Trace back. TheATK 30 is a nice device. ';
my $regex = qr/\s*(ATK 30)\s*/mp;
my $subst = ' \\1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";