# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\/(?:area1|area2))+(\/|$)/$1/gm;t' <<< "/nl/amsterdam/area2/area1
/nl/amsterdam/area2
/nl/amsterdam/area2
/nl/amsterdam/area2/area1"