use strict;
my $str = '/nl/amsterdam/area2/area1
/nl/amsterdam/area2
/nl/amsterdam/area2
/nl/amsterdam/area2/area1';
my $regex = qr`(?:/(?:area1|area2))+(/|$)`mp;
my $subst = '$1';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";