package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:/(?:area1|area2))+(/|$)`)
var str = `/nl/amsterdam/area2/area1
/nl/amsterdam/area2
/nl/amsterdam/area2
/nl/amsterdam/area2/area1`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}