// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:/(?:area1|area2))+(/|$)").unwrap();
let string = "/nl/amsterdam/area2/area1
/nl/amsterdam/area2
/nl/amsterdam/area2
/nl/amsterdam/area2/area1";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}