re = /(?:\/(?:area1|area2))+(\/|$)/m
str = '/nl/amsterdam/area2/area1
/nl/amsterdam/area2
/nl/amsterdam/area2
/nl/amsterdam/area2/area1'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result